Alexa et DOMOTICZ

Discussions concernant la domotique, les objets connectés et tout ce qui se rapporte aux assistants vocaux et leur utilisation en domotique.
StephaneM
Amateur
Amateur
Messages : 270
Enregistré le : ven. 30 nov. 2018 15:54

Re: Alexa et mon appartement

Message par StephaneM » ven. 23 août 2019 23:29

Il faut que tu mettes le pare feu sur faible...

Maison connectée et enceintes Echo ou Google Home

 
Schumi
Membre actif
Membre actif
Messages : 91
Enregistré le : sam. 15 juin 2019 13:06

Re: Alexa et mon appartement

Message par Schumi » sam. 24 août 2019 15:30

Pare feu bien mit sur faible, tout rebooté et même résultat :(

StephaneM
Amateur
Amateur
Messages : 270
Enregistré le : ven. 30 nov. 2018 15:54

Re: Alexa et DOMOTICZ

Message par StephaneM » sam. 24 août 2019 16:56

Oui excuses moi, comme j'ai regardé tes captures cette nuit je n'avais pas les yeux en façe des trous : ta règle NAT / PAT est bien inversée, il faut que le port externe soit le 80, et que le port interne soit 8080, soit pour reprendre la ligne de la règle dans ta capture :

Activer : coché / Application : Web Server (HTTP) / Port interne : 8080 / Port externe : 80 / Protocole : TCP / Equipement : Rasperrypi

Donc c'est bien ce que je pensais qui bloquait, mais bon tu n'as même pas du le voir, tout comme je ne l'ai pas vu sur ta capture :oops: :lol: . Donc il ne te reste plus qu'à inverser tes deux ports (et tu ne fais que ça pour le moment). Si ça fonctionne le http://schumi.xxxxxx.net, alors tu retentes la création de certificat, et tu me dis ce qu'il se passe (j'espère que tu n'as pas flingué l'installation de let's encrypt en supprimant le dossier)

Rappel : on se demande si le processus de création va bien créer le certificat au bon endroit à cause de la commande sudo /etc/letsencrypt/letsencrypt-auto certonly --webroot --email <your email> -d schumi.xxxxxx.net -w ~/domoticz/www/

C'est la partie en rouge pour laquelle j'ai un doute, donc est ce que c'est ~/domoticz/www/ ou /home/pi/domoticz/www/ là je n'en sais rien.... Mais bon l'essentiel c'est de savoir que ce paramètre -w indique simplement l'endroit où Let's Encrypt va écrire le petit fichier qu'il va ensuite essayer de récupérer via HTTP.

ATTENTION : si tu utilises schumi.xxxxxxx.net, le certificat ne fonctionnera que pour cette adresse, si tu veux changer après pour schumi.xxxxxx.eu, il faut refaire le certificat. Si tu te goures dans le schumi.xxxxxx.net dans la commande, ton certificat sera erroné et tu auras une alerte de sécurité quand tu accéderas à https://schumi.xxxxxx.net à travers un navigateur (comme quoi le nom du certificat ne correspond pas)

Schumi
Membre actif
Membre actif
Messages : 91
Enregistré le : sam. 15 juin 2019 13:06

Re: Alexa et DOMOTICZ

Message par Schumi » sam. 24 août 2019 18:00

C’est bon merci ça a marché, j’installerai plus tard ou demain le certificat sur domoticz en attendant le prochain soucis ;)

Schumi
Membre actif
Membre actif
Messages : 91
Enregistré le : sam. 15 juin 2019 13:06

Re: Alexa et DOMOTICZ

Message par Schumi » dim. 25 août 2019 16:55

Bon, j'ai installé le certificat sur domoticz, j'ai remis le parefeu en moyen, supprimé la redirection 80, il reste que la 443.

J'ai aussi remis domoticz en authentification "page de connexion" comme en "basic auth" sur le téléphone ça marche pas et là ca va en page de connexion le log apparait bien.

Mais pour l'application Domoticz ça ne marche toujours pas, je rentre mon adresse de serveur, protocole https, port 443, répertoire vide, mon identifiant et mot de passe, je valide et "erreur de connexion"

Et quand je me connecte à domoticz par mon adresse aussi je vois en haut à droite "Broswer cache refresh failed" "Manifest fetch failed" "https://monadresse/html5.appcache" je sais pas si c'est important ou pas mais ça marche quand même.

StephaneM
Amateur
Amateur
Messages : 270
Enregistré le : ven. 30 nov. 2018 15:54

Re: Alexa et DOMOTICZ

Message par StephaneM » lun. 26 août 2019 11:59

Schumi a écrit :
dim. 25 août 2019 16:55
Bon, j'ai installé le certificat sur domoticz, j'ai remis le parefeu en moyen, supprimé la redirection 80, il reste que la 443.
Malheureusement le certificat n'est pas installé correctement. Si je vais sur https://schumi.xxxxxx.net j'ai toujours une alerte de sécurité concernant le certificat, or c'est justement ce que l'on cherche à éviter.

Pour que l'application Domoticz fonctionne sur le téléphone il faut que ces deux conditions soient vraies : Certificat Let'sEncrypt installé et l'authentification en "Basic Auth".
Et quand je me connecte à domoticz par mon adresse aussi je vois en haut à droite "Broswer cache refresh failed" "Manifest fetch failed"
On verra plus tard, mais à mon avis c'est à cause du certificat qui n'est pas valide.

Donc on vérifie étape par étape :
  1. Que s'est il passé après la commande : sudo /etc/letsencrypt/letsencrypt-auto certonly --webroot --email <your email> -d schumi.xxxxxx.net -w ~/domoticz/www/ ?
  2. Qu'est ce qui s'est passé après les commandes :
    sudo cp ~/domoticz/server_cert.pem ~/domoticz/server_cert.pemold
    sudo cat /etc/letsencrypt/live/schumi.xxxxxx.net/privkey.pem >> ~/domoticz/server_cert.pem
    sudo cat /etc/letsencrypt/live/schumi.xxxxxx.net/fullchain.pem >> ~/domoticz/server_cert.pem
  3. Est-ce que tu as redémarré domoticz ou le raspberry ?
Si tout s'est bien passé alors quand tu vas sur https://schumi.xxxxxxx.net tu dois n'avoir aucune alerte de sécurité et si tu cliques sur le cadenas de ton navigateur pour t'indiquer que la page est sécurisée, tu devrais pour afficher le certificat et vérifié qu'il est bien émis par Let'sEncrypt (à moins que tu n'utilises un logiciel de sécurité ou bloqueur de publicité qui alors afficherait son propre certificat)

Schumi
Membre actif
Membre actif
Messages : 91
Enregistré le : sam. 15 juin 2019 13:06

Re: Alexa et DOMOTICZ

Message par Schumi » lun. 26 août 2019 12:23

Quand j'ai rentré la première commande ça m'a dis que l'étape a été faite avec succès.
Et les trois autres c'est revenu à la ligne à chaque fois.

Je vais remettre en "basic auth" là, redémarrer le raspberry et on verra bien.

J'ai installé la caméra hier, skill dans Alexa installé aussi, bon elle ne me l'affiche pas sur l'écho show et spot, elle me dit à chaque fois la caméra est en veille mais je m'en fou de ça. J'ai cherché à l'installer dans domoticz mais je ne trouve pas l'url, je suis allé sur ce site http://skjm.com/icam/mjpeg_test.php et sur celui là aussi http://www.ispyconnect.com/sources.aspx

Là y'a l'électricien qui me finis de me changer les prises, luminaires et poser les interrupteurs Aqara, on a mis de tout en direct pour l'instant comme on a pas encore trouvé la bonne solution pour laisser le système de l'interrupteur et le couvrir pour les avoirs en secours comme si y'a plus internet, je n'aurais plus de lumière.

Avatar du membre
amenhotep13
Fait partie des meubles
Fait partie des meubles
Messages : 1592
Enregistré le : dim. 22 juil. 2018 18:56

Re: Alexa et DOMOTICZ

Message par amenhotep13 » lun. 26 août 2019 13:28

Là y'a l'électricien qui me finis de me changer les prises, luminaires et poser les interrupteurs Aqara, on a mis de tout en direct pour l'instant comme on a pas encore trouvé la bonne solution pour laisser le système de l'interrupteur et le couvrir pour les avoirs en secours comme si y'a plus internet, je n'aurais plus de lumière.
Le meilleur moyen que je connaisse c'est le système Philips Hue. S'il n'y a plus de lumière c'est qu'il n'y a plus de courant. Dans tous les autres cas de panne, ce n'est pas impacté.

StephaneM
Amateur
Amateur
Messages : 270
Enregistré le : ven. 30 nov. 2018 15:54

Re: Alexa et DOMOTICZ

Message par StephaneM » lun. 26 août 2019 14:09

Schumi a écrit :
lun. 26 août 2019 12:23
J'ai installé la caméra hier, skill dans Alexa installé aussi, bon elle ne me l'affiche pas sur l'écho show et spot
Pour que la caméra soit visible sur le show et le spot : tu vas dans l'application EZVIZ, tu tapotes sur l'image de la caméra, puis sur l'engrenage pour afficher les paramètres de la caméra, dans les paramètres vers la fin tu trouveras "Chiffrement de l'image", il faut désactiver cette option (EZVIZ va t'envoyer un code par e-mail pour que tu puisses le faire)

Et ensuite la caméra est opérationnelle sous les Echo show et spot.

Pour pouvoir accéder à la caméra via un flux RTSP, par exemple sous VLC tu fais ouvrir un flux et là tu tapes :

rtsp://adresse_ip_caméra

L'identifiant est "admin" et le mot de passe tu le trouves sur l'étiquette avec le QRCode au dos de la caméra (c'est ce qu'ils appellent le "Vérification Code" et c'est du type "HRDZTY') si tu vois l'image dans VLC, c'est déjà bien.

C'est le seul flux que la caméra offre et c'est donc ce qu'il faut exploiter pour l'intégrer avec domoticz. Il y a plusieurs solutions pour faire ce que tu veux, le script que je t'avais indiqué ou bien des choses plus complète tel que MotionEye qui est un soft de vidéosurveillance pour Raspberry.
les interrupteurs Aqara, on a mis de tout en direct pour l'instant comme on a pas encore trouvé la bonne solution pour laisser le système de l'interrupteur et le couvrir pour les avoirs en secours comme si y'a plus internet, je n'aurais plus de lumière.
Si tu auras de la lumière avec tes interrupteurs Aquara et Hue même sans Internet. Hue fonctionne sans Internet, Domoticz fonctionne sans Internet, Aquara fonctionne sans Internet. Seule Alexa sera KO.

Schumi
Membre actif
Membre actif
Messages : 91
Enregistré le : sam. 15 juin 2019 13:06

Re: Alexa et DOMOTICZ

Message par Schumi » lun. 26 août 2019 15:48

J'ai remis en "basic-auth", générer un nouveau certificat avec succès, je lance les dernières commandes ça reviens à la ligne sans rien me dire, je redémarre et apparement c'est toujours pareil.

Pour la lumière, j'ai testé en coupant internet et plus rien ne s'allume.

Pour la caméra, je dois aller dans domoticz, "ajouter une caméra" et je rempli "nom", "http", Port 80, identifiant "admin", mot de passe "celui de material code derrière la boite" et url de l'image "rtsp://admin:motdepasse@adresseip/h264_stream c'est bien ça ?

Répondre