Nvidia Shield et Netflix

Une cheminée qui crépite, un fauteuil large et confortable, quelques rafraîchissements : le coin du feu c'est là où se retrouvent les membres de la communauté pour discuter de tous les sujets qui n'ont rien à voir avec la Voix et les assistants vocaux.
Avatar du membre
jlucG
Fait partie des meubles
Fait partie des meubles
Messages : 1406
Enregistré le : dim. 22 juil. 2018 18:56

Nvidia Shield et Netflix

Message par jlucG » jeu. 14 mars 2019 13:09

Depuis quelques temps, quand je regarde Netflix à travers la Shield j'ai un problème de son (aléatoire) au démarrage d'un film (pas tous) en 5.1 : un espèce de grésillement qui ressemble à un tir de mitraillette.

En bidouillant un peu (sortir puis réentrer dans le film ou quitter et revenir dans Netflix ou d'autres manips de cet acabit) au bout d'un moment (plus ou moins long) cela cesse.

Un moyen radical de le faire cesser est de passer en stéréo mais bof!...

Je précise que toute la chaîne audio-vidéo est compatible 4K 30p (shield, TV (c'est elle qui limite à 30p), ampli dernier modèle)

Autre précision : Ce problème n'apparaît que sur Netflix et seulement depuis quelques temps (Kodi, Prime video, Orange TV... tout va bien)

J'ai contacté Netflix, ils m'ont dit que le problème venait de la Shield. J'ai contacté nVidia et devinez quoi... :mrgreen: ils m'ont dit que le problème venait de Netflix.

Quelqu'un a t-il déjà eu un problème similaire ou quelqu'un a t-il une idée ?

Maison connectée et enceintes Echo ou Google Home

 
StephaneM
Membre actif
Membre actif
Messages : 110
Enregistré le : ven. 30 nov. 2018 15:54

Re: Nvidia Shield et Netflix

Message par StephaneM » ven. 15 mars 2019 11:57

Je n'ai aucun problème de 5.1 avec Netflix sur un téléviseur Android TV. Lorsque j'utilisais la MiBox avant de changer de téléviseur je n'avais jamais eu de grésillement non plus en 5.1.

Un exemple de film que je puisse tester le même film (et bande son VO ou VF ?) ? Et le passage en stéréo c'est directement sur la shield (comme il n'ya pas d'options sur Netflix) ?

Le seul truc qui me paraît probable à ce niveau c'est que Netflix utilise quelque chose de différent / nouveau dans son flux dolby digital (par exemple peut être qu'au début le flux a un débit différent comme pour la vidéo, et que c'est un truc nouveau et que pas de bol l'ampli n'apprécie pas cette nouveauté...)

Vu que le son est décodé directement par l'ampli, je ne pense pas que la shield soit responsable...

Par contre Netflix en 4K c'est forcément 4K 60Hz, donc en théorie c'est impossible que soit proposé de la 4K sur la shield dans ces conditions...

Avatar du membre
jlucG
Fait partie des meubles
Fait partie des meubles
Messages : 1406
Enregistré le : dim. 22 juil. 2018 18:56

Re: Nvidia Shield et Netflix

Message par jlucG » ven. 15 mars 2019 13:12

Merci StephaneM de tes explications

Je vais préciser un peu tout en répondant à tes interrogations :)

D'abord je suis toujours en VF (les VO ou VOSTRF très peu pour moi :? )

Pour le passage en stéréo, c'est directement dans les options audio du film donc sur Netflix

Exemple de film : la série Prison Break ou Arrow ou... Mais la même chose peut amener le problème un soir et pas le lendemain... C'est complètement aléatoire (apparemment). Hier soir, par exemple, aucun problème... :roll:

La shield me propose la 4K 60hz et la 4K 30Hz mais la 4K 60Hz est grisée dans ses options (elle doit voir que la télé bride le flux à 30Hz)

Cà vient peut-être des réglages affichage et audio de la shield ?
reglage1.jpg
reglage1.jpg (35.44 Kio) Vu 453 fois
reglage2.jpg
reglage2.jpg (28.17 Kio) Vu 453 fois
reglage3.jpg
reglage3.jpg (31.04 Kio) Vu 453 fois

Avatar du membre
jlucG
Fait partie des meubles
Fait partie des meubles
Messages : 1406
Enregistré le : dim. 22 juil. 2018 18:56

Re: Nvidia Shield et Netflix

Message par jlucG » ven. 15 mars 2019 13:13

edit : il manque un fichier
reglage4.jpg
reglage4.jpg (43.11 Kio) Vu 452 fois
compare à tes propres réglages stp
Modifié en dernier par jlucG le ven. 15 mars 2019 13:16, modifié 1 fois.

Avatar du membre
jlucG
Fait partie des meubles
Fait partie des meubles
Messages : 1406
Enregistré le : dim. 22 juil. 2018 18:56

Re: Nvidia Shield et Netflix

Message par jlucG » ven. 15 mars 2019 13:15

Mon problème n'intéresse peut-être pas tout le monde...

Si un admin veut supprimer ce post, il est prié de m'envoyer son contenu en MP pour que je puisse en conserver la teneur

Merci

Avatar du membre
jlucG
Fait partie des meubles
Fait partie des meubles
Messages : 1406
Enregistré le : dim. 22 juil. 2018 18:56

Re: Nvidia Shield et Netflix

Message par jlucG » sam. 16 mars 2019 11:49

J'ai trouvé le coupable : c'est l'appli Kodi.

D'ailleurs le problème n'est pas que sur Netflix. Sur Prime video aussi.

Et l'apparition de mon problème correspond peu ou prou à la dernière mise à jour de Kodi vers la version 18 Leia.

Un des paramètres a dû être modifié, il ne me reste plus qu'à trouver le(s)quel(s).

Je vous tiens au courant...pour le cas où d'autres auraient le même problème🙂

StephaneM
Membre actif
Membre actif
Messages : 110
Enregistré le : ven. 30 nov. 2018 15:54

Re: Nvidia Shield et Netflix

Message par StephaneM » sam. 16 mars 2019 12:28

La vache ils n'ont pas lésinés sur les réglages... Sur la MiBox il n'y en a pas autant.

A priori il n'y a rien d'incohérent... Sauf un truc qui me chiffonne : le shield elle est directement connectée au téléviseur, et le téléviseur est lui connecté sur l'ampli qui restitue le son via ARC ?

Si pas déjà testé j'opterais plutôt pour le branchement inverse : la shield sur l'ampli (donc le son est décodé directement par l'ampli plutôt que de transiter par le téléviseur).

Les deux branchements sont corrects, il n'y en a pas un meilleur qu'un autre sauf dans le cas ou l'ARC (qui n'est pas encore eARC partout) devient un facteur limitant et empêche le décodage de format particuliers (je pense à l'ATMOS qui s'il peut marcher avec de l'ARC ce n'est pas forcément évident). L'inverse est également vrai le fait de passer par l'ampli, peut empêcher certains formats vidéo de passer (typiquement avec mon PC je ne peut sortir à travers l'ampli qu'en 8 bits / pixels, alors que sur la TV directement je pouvais sortir en 10 et 12 bits... je n'ai pas encore compris pourquoi...)

Reste que je ne comprends pas pourquoi KODI aurait foutu le bordel comme ça (il modifierait le format du son ou s'interposerait entre Netflix et la sortie son...)

Pour les paramètres sinon je virerais l'expension de la stéréo en 5.1 (c'est typiquement l'ampli qui doit gérer ça tout seul), j'activerais probablement le volume fixe également (pareil c'est sur l'ampli que doit être effectué le contrôle du volume)

Avatar du membre
jlucG
Fait partie des meubles
Fait partie des meubles
Messages : 1406
Enregistré le : dim. 22 juil. 2018 18:56

Re: Nvidia Shield et Netflix

Message par jlucG » sam. 16 mars 2019 12:56

Mon schéma de connection est le suivant : un court croquis vaut mieux qu'un long discours ;)
reseau mm.jpg
reseau mm.jpg (60.08 Kio) Vu 410 fois
Kodi est configuré en pass-through

Je vais essayer le modifier les deux paramètres dont tu parles sur la shield

StephaneM
Membre actif
Membre actif
Messages : 110
Enregistré le : ven. 30 nov. 2018 15:54

Re: Nvidia Shield et Netflix

Message par StephaneM » sam. 16 mars 2019 16:49

Oui comme ça c'est tout bon. J'ai été induit en erreur par deux choses : le fait d'avoir le contrôle IR pour le volume du Denon par la shield et par le fait que tu dises que c'était la TV qui limitait la shield à du 30 Hz.

A ce sujet il paraît qu'il n'est pas inutile lors de cas comme ça d'utiliser le port HDMI en entrée de l'ampli le plus proche du port HDMI de sortie vers la TV... En effet la "distance" entre le port d'entrée et de sortie étant moins grande ça peut régler des pbms tels que le 60Hz qui ne passe pas. Sur le Denon que j'utilise le port HDMI le plus proche du port de sortie c'est justement pas le port 1, mais le dernier...

Kodi en passthrough, c'est effectivement Ok aussi, il se content simplement de balancer le flux digital tel quel sur la sortie numérique...

Avatar du membre
jlucG
Fait partie des meubles
Fait partie des meubles
Messages : 1406
Enregistré le : dim. 22 juil. 2018 18:56

Re: Nvidia Shield et Netflix

Message par jlucG » sam. 16 mars 2019 19:09

J'ai déplacé le port HDMI de la shield sur l'ampli et l'ai placé en n°7 (la dernière position) mais çà ne change rien au pb du 60Hz vu que la TV bride à 30Hz. Mais çà ne peut pas faire de mal :)

J'ai joué aussi sur les 2 paramètres :
*expansion stereo en 5.1 PCM => çà ne change rien si ce n'est que le menu de la shield est en stereo au lieu de NeuralX. Mais bon pour entendre des "tic" à l'appui sur un bouton... :D
*volume fixe : effectivement c'est l'ampli du coup qui gère tout le volume (et donc Alexa par l'intermédiaire de la skill Heos) mais du coup la télécommande de la shield n'agit plus sur le volume. Elle était quand même bien pratique en glissant le doigt... Et comme le spot est à côté d'une enceinte latérale, monter le volume ne pose pas de problème mais le baisser... faut crier un peu :D

Mon problème de bruit de mitraillette est réglé : j'ai désinstallé puis réinstallé Kodi et plus de bruit.
Par contre j'ai perdu tout ce que j'avais installé comme extensions (heureusement y'en avait pas beaucoup) et tous les paramètres de configuration :cry:

Répondre